2016年9月15日木曜日

CentOS6.にpip3を入れ…入らねーよ


まずPython-3を入れる
make install …したあたりでIgnoring ensurepip failure: pip 7.1.2 requires SSL/TLS …エラー

python get-pip.py してみるImportError: cannot import name 'HTTPSHandler' …エラーである
そりゃそうだPythonの段階で弾かれてるんだもん。しょうがないので、世間の文献をみるといっぱい同じ文言が出てくる。OPENSSLが入ってないから…いやいやいや、入ってるんだよ。なんども入れたさ。抜いたり入れたり。
yum install openssl-devel

なんかのpathが通ってないとか、違う場所にインストールされちゃってるのかん…そんなのはyumに聞いてくれ。そこまで知識は深くないし調べる時間もないんで、あきらめようと思ったんだけど、試しにいれたPython3のどれかのバージョンで入るんじゃね?と思って、一つづつためしたら…

python3.3  get-pip.py …通りやがった!!# pip -Vpip 8.1.2 from /usr/lib/python3.3/site-packages (python 3.3)

深いことは考えない…(考える頭はない)pip3がインストールされたので良しとしよう。

これで無事にacdcliが試せる <ここが本題…ここにたどり着くのにえらく時間がかかった…。pip3 install acdcli

0 件のコメント:

コメントを投稿